You need to have JAVA installed and allow scripting & active content